Rocket League Matchmaking Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 17:16 UTC

Investigating

We're aware of issues impacting Rocket League Matchmaking and are currently investigating.
Posted Nov 19, 2025 - 16:35 UTC
This incident affected: Rocket League (Game Services, Matchmaking, Stats and Leaderboards, Parties, Friends, and Messaging).