Issues with Epic Online Services Authentication
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Aug 18, 2020 - 13:51 UTC
Investigating
We are experiencing intermittent service issues. Some players may be unable to access the online services.
Posted Aug 18, 2020 - 12:52 UTC
This incident affected: Epic Online Services (Authentication).