EOS Log-Ins Impacted

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 09:23 UTC

Monitoring

We’re working to resolve an issue related to EOS log-ins and will update this once fully recovered.
Posted Oct 23, 2025 - 08:39 UTC
This incident affected: Epic Online Services (Epic Account Services - Authentication).