Fall Guys Item Shop Purchases Error

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 00:55 UTC

Investigating

Players on Xbox may see purchases fail when using the Item Shop in game.
Posted Feb 24, 2026 - 23:16 UTC
This incident affected: Fall Guys (Item Shop).