Epic Online Services Issue
Incident Report for Epic Games Public
Resolved
Issues with the launcher and online services have been resolved and returned to normal.
Posted May 23, 2020 - 16:15 UTC
Update
We are continuing to monitor the situation and will keep you updated.
Posted May 23, 2020 - 15:43 UTC
Investigating
We are aware that players are experiencing issues with the Epic Games Launcher and online services. We’re investigating, and we’ll provide an update as soon as we can.
Posted May 23, 2020 - 15:23 UTC
This incident affected: Epic Online Services (Authentication, P2P Networking (STUN/TURN), Matchmaking, Player Data Storage, Stats, Achievements, Leaderboards, Lobbies).