Email backlog
Incident Report for Epic Games Public
Resolved
We've resolved the issue causing emails to be delayed. The backlog is now cleared and players should receive all email notifications immediately.
Posted 6 months ago. Apr 12, 2018 - 19:11 UTC
Identified
We have identified an issue with our email service becoming backlogged.
This is resulting in delayed emails of all kinds, including but not limited to 2-factor authentication codes and password resets.
We apologize for these delays and are actively working to resolve this.
Posted 6 months ago. Apr 11, 2018 - 17:56 UTC