Facebook Log-in Temporarily Unavailable

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 04:42 UTC

Investigating

Logging into Epic Games Store via your Facebook log-in credentials is temporarily unavailable. We'll update this once its restored.
Posted Jun 05, 2026 - 00:57 UTC
This incident affected: Epic Games Store (Login).