Delayed Email 2FA Verification
Incident Report for Epic Games Public
Resolved
This incident is resolved and email services have returned to normal
Posted Oct 08, 2024 - 00:51 UTC
Investigating
We're investigating an issue with our services, and players may experience a delay in receiving 2-Factor Authentication confirmation emails. If this happens, we advise waiting a few moments before attempting again.
Posted Oct 07, 2024 - 23:26 UTC
This incident affected: Epic Online Services (Epic Account Services - Authentication).