Epic Online Services - P2P Networking
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 21:48 UTC
Monitoring
We’re monitoring P2P networking issues affecting load and connection times.
Posted Nov 20, 2020 - 17:12 UTC
This incident affected: Epic Online Services (P2P Networking (STUN/TURN)).