Rocket League Major Outage - April 4, 2022
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Apr 04, 2022 - 18:41 UTC
Investigating
We are currently investigating this issue.
Posted Apr 04, 2022 - 18:21 UTC
This incident affected: Rocket League (Login, Game Services, Matchmaking, Stats and Leaderboards, Item Shop, Parties, Friends, and Messaging).