Support-A-Creator Website Temporarily Unavailable
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 14:07 UTC
Update
We've fixed the issue and the Support-A-Creator website is now back online.
Posted Nov 19, 2024 - 23:03 UTC
Investigating
We've taken the Support-A-Creator website down while we investigate an issue.
Posted Nov 19, 2024 - 20:49 UTC
This incident affected: Support-A-Creator (Website/Portal).