EOS/Fall Guys Matchmaking Issues

Incident Report for Epic Games Public

Resolved

Matchmaking services have been restored. We are continuing to monitor the situation to ensure stability.
Posted Jul 06, 2025 - 07:25 UTC

Investigating

We're investigating matchmaking issues affecting Epic Online Services and Fall Guys. We're actively working on a fix and will share another update when we have more info, or once this is resolved.
Posted Jul 06, 2025 - 05:38 UTC
This incident affected: Fall Guys (Matchmaking) and Epic Online Services (Sessions, Matchmaking).