Epic Online Services Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted May 23, 2020 - 18:12 UTC
Investigating
We are aware that players are experiencing issues with the Epic Games Launcher and online services. We’re investigating, and we’ll provide an update as soon as we can.
Posted May 23, 2020 - 17:55 UTC
This incident affected: Epic Online Services (Authentication, Matchmaking, Stats, Leaderboards).