Rocket League: PC Client Closing Error
Incident Report for Epic Games Public
Resolved
This issue has been resolved. No game update is required.
Posted Feb 09, 2022 - 22:29 UTC
Investigating
We are aware that Rocket League on PC is not properly closing when players exit the game. We are investigating this issue.
Posted Feb 09, 2022 - 20:12 UTC
This incident affected: Rocket League (Game Services).