Epic Online Services: Issue with Purchasing
Incident Report for Epic Games Public
Resolved
The issue affecting purchasing through Epic Online Services has been resolved.
Posted Apr 28, 2021 - 01:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2021 - 00:48 UTC
Investigating
We're currently investigating an issue affecting purchasing through Epic Online Services. We'll provide an update when this is resolved.
Posted Apr 28, 2021 - 00:48 UTC
This incident affected: Epic Online Services (Purchasing).