Fab sellers unable to publish or update listings

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Dec 30, 2025 - 15:30 UTC

Investigating

We're investigating an issue where Fab Sellers aren't able to publish or update listings.
Posted Dec 30, 2025 - 14:35 UTC
This incident affected: Fab.