Scheduled maintenance on our Party Services at 5 AM ET
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 8 days ago. Apr 16, 2019 - 10:53 UTC
Investigating
We will be performing scheduled maintenance on our Party Services at 5 AM ET (0900 UTC) on April 16. You may notice degraded performance on some functionality during this time
Posted 9 days ago. Apr 15, 2019 - 21:10 UTC