Emails for 2FA and for Resetting Password
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Feb 17, 2021 - 03:33 UTC
Investigating
We're aware of an issue involving some players currently not receiving emails for 2FA enrollment or for resetting their password. We're working to address this and will provide an update when this is resolved.
Posted Feb 16, 2021 - 23:56 UTC
This incident affected: Epic Online Services (Authentication).