Rocket League Sideswipe Connection Issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 23:55 UTC
Investigating
We're actively investigating Matchmaking and general connection issues on Rocket League Sideswipe.
Posted Nov 13, 2024 - 22:57 UTC
This incident affected: Rocket League Sideswipe (Game Services, Matchmaking).