Metahuman and Twinmotion Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Oct 11, 2023 - 10:19 UTC
Investigating
We're investigating issues logging in and navigating the websites for Twinmotion and Metahuman services, and UEFN's integration with URC. We'll provide another update when this is resolved.
Posted Oct 11, 2023 - 09:45 UTC
This incident affected: Twinmotion Cloud (Drive, Pixel Streaming) and MetaHuman Creator.