Issues with logins, party services and purchases on Epic Games Store
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Mar 04, 2020 - 09:45 UTC
Investigating
We are currently investigating this issue.
Posted Mar 04, 2020 - 09:40 UTC
This incident affected: Battle Breakers (Login, Friends), Fortnite (Login, Parties, Friends, and Messaging), and Epic Games Store.