Rocket League Matchmaking Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Mar 14, 2026 - 01:38 UTC

Investigating

We’re aware of reports of matchmaking issues in Rocket League.
Our team is currently investigating and we’ll provide an update as soon as we have a fix.
Posted Mar 14, 2026 - 01:02 UTC
This incident affected: Rocket League (Game Services, Matchmaking, Stats and Leaderboards, Parties, Friends, and Messaging, Voice Chat).