Fortnite Battle Royale: Leaderboard Loading
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 15:38 UTC
Investigating
Leaderboard loading is currently degraded as we work on maintenance. However, all stats are still being recorded.
Posted Mar 16, 2020 - 18:35 UTC
This incident affected: Fortnite (Stats and Leaderboards).