Fortnite.com is currently down
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Mar 04, 2021 - 20:30 UTC
Investigating
We are currently investigating this issue.
Posted Mar 04, 2021 - 20:01 UTC
This incident affected: Fortnite (Website).