Matchmaking Issues

Incident Report for Epic Games Public

Resolved

Matchmaking services have been restored.
Posted Mar 02, 2026 - 17:20 UTC

Investigating

We’re currently investigating an issue affecting matchmaking services in the Middle East region. Users may experience longer queue times or difficulty finding matches.

We'll provide updates as more information becomes available.
Posted Mar 02, 2026 - 06:16 UTC
This incident affected: Rocket Racing (Matchmaking), Rocket League (Matchmaking), and Fortnite (Matchmaking).