V-Bucks Delivery Delayed

Incident Report for Epic Games Public

Resolved

Players who saw a delay in receiving V-Bucks should now have them available.

As part of this fix, players who qualify for the Showdown Umbrella styles introduced in today's update may see them granted at a later date.
Posted May 14, 2026 - 17:26 UTC

Identified

We're working to fix a delay with purchased V-Bucks being granted for some players. All purchases are saved and will appear ASAP once we fix this error.
Posted May 14, 2026 - 15:22 UTC
This incident affected: Fortnite (Item Shop).