Issues with one-time paypal payments
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 13, 2019 - 12:23 UTC
Investigating
We are currently investigating the issue.
Posted about 1 month ago. Sep 13, 2019 - 09:35 UTC
This incident affected: Epic Games store.