Login and Matchmaking Errors

Incident Report for Epic Games Public

Resolved

Log-in and Matchmaking has recovered and we're no longer seeing any server delays. We'll continue to monitor these services and address any issues that arise.
Posted May 08, 2026 - 01:45 UTC

Update

We're actively working to fix the Log-in & Matchmaking outages players are experiencing across Fortnite, Fall Guys, and Rocket League.

Purchases on Epic Games Store may encounter a delay. We'll provide more info as we resolving this issue.
Posted May 08, 2026 - 00:55 UTC

Investigating

Players may not be able to log into or matchmake in Fortnite or Fall Guys. We're working to fix this now and we'll provide an update when we have more info.
Posted May 08, 2026 - 00:33 UTC
This incident affected: Rocket League (Login), Fall Guys (Login, Matchmaking), Fortnite (Login, Matchmaking), and Epic Games Store (Purchasing/Refunding).