Degraded Notification Services
Incident Report for Epic Games Public
Resolved
We've identified the cause of the problem and deployed a fix.

This issue is now resolved, thank you for your patience.
Posted Sep 18, 2020 - 21:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2020 - 20:45 UTC
Investigating
We're aware of an issue affecting our Notification Services. Players may notice notifications are delayed or not appearing at this time.

We're working to resolve this problem.
Posted Sep 18, 2020 - 20:03 UTC
This incident affected: Epic Online Services (Achievements).