Fortnite Battle Royale: Server Issues in Middle East Server Region
Incident Report for Epic Games Public
Resolved
The server issues in the Middle East server region are now resolved.
Posted Jul 01, 2020 - 00:02 UTC
Investigating
We're currently investigating server issues in the Middle East server region in Fortnite Battle Royale.
Posted Jun 30, 2020 - 16:31 UTC
This incident affected: Fortnite (Game Services).