Games are not showing up on the Epic Games Store
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jun 30, 2020 - 08:08 UTC
Update
We are continuing to investigate this issue.
Posted Jun 30, 2020 - 07:52 UTC
Investigating
We are currently investigating this issue.
Posted Jun 30, 2020 - 07:50 UTC
This incident affected: Epic Games Store.