Epic Games Store: Chase Refunds Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 22:56 UTC
Identified
We're aware of an issue with refunds for players who made their purchase via Chase. We're working with Chase to resolve the issue.
Posted May 30, 2021 - 22:24 UTC
This incident affected: Epic Games Store (Purchasing/Refunding).