Epic Games Store Browsing Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Dec 30, 2021 - 23:46 UTC
Investigating
We're currently investigating an issue where players are having difficulty browsing the Store or pages failing to load. We'll provide an update when this is resolved.
Posted Dec 30, 2021 - 20:52 UTC
This incident affected: Epic Games Store (Store Browsing).