Fortnite NAE and EU Matchmaking Issue
Incident Report for Epic Games Public
Resolved
Matchmaking in the NAE and EU regions have returned to normal.
Posted Dec 03, 2020 - 18:49 UTC
Investigating
We are investigating Fortnite matchmaking issues in the NAE and EU regions. We'll update you when this is resolved.
Posted Dec 03, 2020 - 17:47 UTC
This incident affected: Fortnite (Matchmaking).