Twinmotion Cloud Outage - 10/20/2024
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Oct 21, 2024 - 18:12 UTC
Investigating
Twinmotion Cloud is currently unavailable, and we are investigating. The Twinmotion desktop app can still be used during this outage.
Posted Oct 21, 2024 - 00:58 UTC
This incident affected: Twinmotion Cloud (Drive, Pixel Streaming).