High Ping in Creative Mode in Saudi Arabia
Incident Report for Epic Games Public
Resolved
Due to an undersea cable cut, we’ve been forced to run Creative matches outside of the region. We are continuing to pursue better mitigation strategies while we wait for the undersea cable to be repaired.
Posted 8 days ago. Sep 10, 2019 - 19:18 UTC
Investigating
We're aware that some players in Saudi Arabia are experiencing high ping in Creative Mode. We're investigating this issue and will provide an update when it is resolved.
Posted 8 days ago. Sep 10, 2019 - 14:02 UTC