Rocket League - Matchmaking Issues and Server Latency
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jan 12, 2024 - 21:41 UTC
Investigating
We're aware that players are experiencing issues matchmaking as well as some server latency.
Posted Jan 12, 2024 - 18:27 UTC
This incident affected: Rocket League (Game Services, Matchmaking).