Issues with Epic Online Services authentification services
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Mar 10, 2022 - 14:44 UTC
Investigating
We are currently investigating this issue.
Posted Mar 10, 2022 - 14:07 UTC
This incident affected: Epic Online Services (Authentication).