Fortnite Battle Royale: Career Stats and Leaderboards
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Mar 21, 2020 - 16:46 UTC
Update
Lifetime career stats are undergoing maintenance.

All stats are still being recorded and updates to your career will be reflected when the maintenance is completed.
Posted Mar 19, 2020 - 21:07 UTC
Identified
Stats and Leaderboards in the Career tab are currently degraded as we work on maintenance. However, all stats are still being recorded.
Posted Mar 19, 2020 - 18:54 UTC
This incident affected: Fortnite (Stats and Leaderboards).