Fortnite Item Shop Missing Offers
Incident Report for Epic Games Public
Resolved
Offers in the Item Shop have returned.
Posted May 03, 2024 - 03:11 UTC
Investigating
The Item Shop is only displaying real-money offers, we're working to resolve this now.
Posted May 03, 2024 - 02:30 UTC
This incident affected: Fortnite (Item Shop).