Purchasing Failures for PC/Mac/Android
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Dec 21, 2019 - 04:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 21, 2019 - 04:14 UTC
Update
We are continuing to investigate this issue.
Posted Dec 21, 2019 - 01:44 UTC
Update
We are continuing to investigate this issue.
Posted Dec 21, 2019 - 01:43 UTC
Investigating
We're currently investigating an issue where players are unable to make purchases.
Posted Dec 21, 2019 - 01:01 UTC
This incident affected: Epic Games Store, Battle Breakers (Item Shop), and Fortnite (Item Shop).