EOS Login Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 02:03 UTC

Investigating

We are currently investigating this issue.
Posted Mar 26, 2025 - 01:29 UTC
This incident affected: Epic Online Services (Epic Account Services - Authentication, Game Services - Authentication, Epic Games Store Ecommerce).