Epic Games Login Issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Oct 01, 2022 - 00:08 UTC
Investigating
We are aware of and investigating an issue with Epic Games Login service
Posted Sep 30, 2022 - 21:49 UTC
This incident affected: Fall Guys (Login), Rocket League (Login), Rocket League Sideswipe (Login), Epic Games Store (Login), Fortnite (Login), Epic Online Services (Authentication), and Battle Breakers (Login).