Epic Games Launcher: Game Libraries Not Appearing Correctly
Incident Report for Epic Games Public
Resolved
The issue has been resolved and game libraries are now appearing correctly.
Posted Aug 23, 2020 - 18:27 UTC
Investigating
We're aware of an issue impacting game libraries not appearing correctly for some players. We're investigating this and will keep you updated as we have more info.
Posted Aug 23, 2020 - 17:45 UTC
This incident affected: Epic Games Store (Login).