Login Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Mar 16, 2018 - 01:33 UTC
Monitoring
The login and signup issues for Fortnite mobile, our website and launcher are now solved.
Posted Mar 16, 2018 - 00:59 UTC
Update
Epic Games Launcher primary login flow is now restored. Google and Facebook login remain blocked for the Launcher at this time, but should be operational soon
Continuing work to bring websites back online.
Posted Mar 16, 2018 - 00:46 UTC
Identified
Players are currently blocked from accessing the Epic Games launcher and websites. In addition, players will be unable to access Fortnite Mobile with PSN or Xbox credentials. We're working to resolve the issue as soon as possible.
Posted Mar 16, 2018 - 00:06 UTC
Investigating
We are investigating an issue with login services for our websites and Fortnite mobile.
Posted Mar 15, 2018 - 23:04 UTC