Matchmaking issues in LEGO Fortnite Odyssey

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 18:06 UTC

Investigating

We are investigating an issue causing some players not to be able to matchmake in LEGO Fortnite Odyssey. We'll let you know once the fix is ready or when we have more info.
Posted Aug 19, 2025 - 17:48 UTC
This incident affected: LEGO Fortnite (Matchmaking).