Stats Delayed

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted May 18, 2026 - 23:51 UTC

Identified

We are aware of delays impacting stats queries and reporting surfaces in Epic Online Services. Stats ingestion and processing are continuing normally, but some results may appear delayed while processing catches up.
Posted May 18, 2026 - 23:13 UTC
This incident affected: Epic Online Services (Stats).