Scheduled Maintenance - v4.3 Update
Incident Report for Epic Games Public
Resolved
Patch v4.3 has been deployed and the update is complete.
Posted 3 months ago. May 30, 2018 - 09:29 UTC
Monitoring
Update v4.3 has been deployed and we are now monitoring the servers.
Posted 3 months ago. May 30, 2018 - 08:57 UTC
Identified
Fortnite servers are offline while we update to v4.3
Posted 3 months ago. May 30, 2018 - 07:27 UTC