GeForce NOW Login Issues in Fortnite

Incident Report for Epic Games Public

Resolved

✅ Login services have returned to normal. Players on GeForce NOW should now be able to log into Fortnite as expected.
Posted Sep 15, 2025 - 21:13 UTC

Investigating

Players using the GeForce NOW service may be experiencing login issues in Fortnite.

We'll share an update as soon as we have more details or a fix is in place.
Posted Sep 15, 2025 - 19:20 UTC
This incident affected: Fortnite (Login).