Delayed Email Verification and Account Creation Emails
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 11:13 UTC
Investigating
We're continuing to investigate an issue with our email services, which is causing a delay emails including 2-Factor Authentication or new Account Creation confirmation. Received emails may be expired by the time they arrive, we're working on a fix for this now.
Posted Oct 08, 2024 - 10:26 UTC
This incident affected: Epic Online Services (Epic Account Services - Authentication).